Планировщик заданий

Планировщик заданий предназначен для планирования выполнения в указанное время команд, программ или сценариев.

  • Перед использованием планировщика заданий просмотрите раздел Операции.
  • Для получения справки о выполнении определенных задач откройте раздел Инструкции.
  • Общее описание содержится в разделе Общие сведения.
  • Сведения о разрешении вопросов применения содержатся в разделе Устранение неполадок.


Операции планировщика заданий

Операции

Следующая таблица содержит список типичных действий, выполняемых с помощью планировщика заданий. Для получения полного списка инструкций планировщика откройте раздел Инструкции.

Операция | Ссылка
Перед тем как запланировать выполнение задания необходимо добавить задание. | Назначение нового задания
Когда задания созданы, нетрудно изменить программу, расписание или параметры определенного задания. | Изменение назначенного задания
Имеется возможность полностью удалить назначенные задания, выполнение которых больше не требуется. | Удаление назначенного задания
В случае запуска назначенного задания в то время, когда компьютер используется, можно прекратить выполнение задания, а позже восстановить его выполнение. | Прекращение выполнения текущего задания
Имеется возможность временно остановить выполнение всех назначенных заданий, а позже продолжить их выполнение. | Временное отключение всех назначенных заданий


Инструкции...

  • Планирование заданий
  • Управление планировщиком заданий


Планирование заданий
  • Запуск планировщика заданий
  • Назначение нового задания
  • Изменение назначенного задания
  • Удаление назначенного задания
  • Прекращение выполнения текущего задания
  • Принудительное выполнение задания


Запуск планировщика заданий

  • Откройте окно планировщика заданий, дважды щелкнув значок Мой компьютер, а затем дважды щелкните значок Назначенные задания.
  • Чтобы запустить мастер планирования заданий, дважды щелкните значок Назначенные задания, а затем дважды щелкните значок Добавить задание.


Назначение нового задания
  1. Запустите планировщик заданий.
  2. Дважды щелкните значок Добавить задание.
  3. Выполняйте инструкции, выводящиеся на экран в окнах мастера планирования заданий.

Примечания

  • Если требуется установить дополнительные параметры задания, установите флажок Установить дополнительные параметры после нажатия кнопки "Готово" в последнем окне мастера.
  • Для повторения запуска нового задания при каждом его выполнении установите флажок Установить дополнительные параметры после нажатия кнопки "Готово" в последнем окне мастера, выберите вкладку Расписание и нажмите кнопку Дополнительно.
  • Если для программы задания требуются параметры, установите флажок Установить дополнительные параметры после нажатия кнопки "Готово" в последнем окне мастера, выберите вкладку Задание и введите параметры в поле Запуск вслед за путем к программе.
  • Проверьте правильность системной даты и времени на компьютере. Планировщик заданий использует системную дату и время при выполнении назначенных заданий. Для проверки или изменения даты и времени дважды щелкните значение времени на панели задач.


Изменение назначенного задания
  1. Запустите планировщик заданий.
  2. Щелкните правой кнопкой задание, которое требуется изменить, и выберите команду Свойства.
  3. Выполните одно из следующих действий.
    • Чтобы сменить запускаемую программу, введите путь к программе в поле Запуск.
    • Чтобы изменить расписание задания, выберите вкладку Расписание.
    • Чтобы изменить настройку задания, выберите вкладку Настройка.

Примечания

  • При смене учетной записи пользователя для запускаемой программы необходимо ввести пароль для этой учетной записи.
  • Если программе требуется передать параметры командной строки, введите их после пути в поле Запуск.
  • Если полный путь к программе включает пробелы, заключите его в символы двойных кавычек (").
  • Проверьте правильность системной даты и времени на компьютере. Планировщик заданий использует при выполнении назначенных заданий системную дату и время. Для проверки или изменения даты и времени дважды щелкните значение времени на панели задач.


Удаление назначенного задания
  1. Запустите планировщик заданий.
  2. Щелкните правой кнопкой задание, которое требуется удалить, и выберите команду Удалить.

Примечания

  • После удаления назначенного задания его значок удаляется из списка заданий. Файл программы не удаляется с жесткого диска.
  • Можно также удалить задание с помощью клавиши DELETE.


Прекращение выполнения текущего задания
  1. Запустите планировщик заданий.
  2. Щелкните правой кнопкой задание, которое требуется остановить, и выберите команду Завершить.

Примечания

  • Если в назначенном задании запускается другая программа, то данная команда приведет к остановке только исходного назначенного задания. Второе задание будет выполняться.
  • Чтобы снова запустить остановленное задание, щелкните правой кнопкой значок задания и выберите команду Запустить.


Принудительное выполнение задания
  1. Запустите планировщик заданий.
  2. Щелкните правой кнопкой задание, которое требуется выполнить, и выберите команду Запустить.

Примечания

  • Чтобы прекратить выполнение задания, выберите в меню Файл команду Завершить.
  • Если задание не запускается, проверьте причину по журналу. В меню Дополнительно выберите команду Просмотр журнала.


Управление планировщиком заданий
  • Просмотр журнала выполнения заданий
  • Просмотр назначенных заданий на удаленных компьютерах
  • Временное отключение всех назначенных заданий
  • Остановка планировщика заданий
  • Указание учетной записи для службы At


Просмотр журнала выполнения заданий
  1. Запустите планировщик заданий.
  2. В меню Дополнительно выберите команду Просмотр журнала.


Просмотр назначенных заданий на удаленных компьютерах
  1. На рабочем столе дважды щелкните значок Сетевое окружение.
  2. Дважды щелкните значок компьютера, на котором требуется просмотреть назначенные задания.
  3. Выберите Назначенные задания.

Примечания

  • Просматривать задания на удаленном компьютере с операционной системой Windows может только пользователь, являющийся администратором удаленного компьютера.
  • Изменять задания на удаленном компьютере с операционной системой Windows можно только в том случае, если на удаленном компьютере установлено программное обеспечение для удаленного доступа к системному реестру и назначен общий ресурс x$, где x представляет жесткий диск, на котором находится папка Назначенные задания. Кроме того, на компьютере с системой Windows или более поздней ваша учетная запись должна иметь разрешения удаленного управления. Чтобы указать пользователей, имеющих право на удаленное управление компьютером, выберите значок Пароли на панели управления.


Временное отключение всех назначенных заданий
  1. Запустите планировщик заданий.

  2. В меню Дополнительно выберите команду Приостановить планировщик.

Примечания

  • Это полезно при выполнении другой программы (например игровой) или при установке программного обеспечения, когда назначенное задание может оказаться помехой.
  • Задания, которые не были выполнены во время приостановки планировщика заданий, будут запущены в следующее время выполнения по графику после запуска планировщика.
  • Чтобы возобновить выполнение заданий, выберите в меню Дополнительно команду Возобновить работу планировщика.


Остановка планировщика заданий
  1. Запустите планировщик заданий.
  2. В меню Дополнительно выберите команду Остановить планировщик.

Примечание

  • После выключения планировщика заданий назначенные задания не выполняются и планировщик заданий не запускается автоматически при следующем запуске Windows.


Указание учетной записи для службы At
  1. Запустите планировщик заданий.
  2. В меню Дополнительно выберите команду Учетная запись службы AT.
  3. Выберите параметр Эта учетная запись, а затем введите учетную запись пользователя, которая будет использоваться для выполнения заданий, назначенных с помощью командыat.
  4. Введите пароль учетной записи в поля Пароль и Подтверждение пароля.

Примечания

  • Служба AT доступна только в системе Windows NT.
  • Можно также выбрать параметр Системная учетная запись. В этом случае планировщик заданий запускает задания с помощью команды at с использованием учетной записи LocalSystem, которой требуются права администратора.

  • Указанная учетная запись должна иметь привилегии, достаточные для выполнения любых заданий, назначенных с помощью команды at. Например, если назначается запуск программ, которые могут выполняться только администраторами, то указанная учетная запись пользователя должна быть учетной записью администратора.


Общие сведения

Данный раздел содержит общие сведения о планировщике заданий.

  • Введение
  • Использование планировщика заданий
  • Планировщик заданий и команда at
  • Планировщик заданий и безопасность
  • Устранение неполадок


Планировщик заданий

Программа планировщика заданий является средством назначения заданий (таких как дефрагментация диска) для выполнения в наиболее удобное время. Планировщик заданий запускается при каждом запуске Windows и выполняется в фоновом режиме.

Планировщик заданий позволяет:

  • назначить задание для выполнения ежедневно, еженедельно, ежемесячно или в указанной время, например, при запуске или во время простоя компьютера;
  • изменить расписание выполнения задания;
  • остановить назначенное задание;
  • назначить параметры выполнения задания в указанное время.


Использование планировщика заданий

Операционная система Windows автоматически устанавливает планировщик заданий. Чтобы воспользоваться его службами, дважды щелкните значок Назначенные задания в папке Мой компьютер.

Чтобы запустить мастер планирования заданий, дважды щелкните значок Добавить задание. Для добавления заданий можно воспользоваться перетаскиванием сценариев, программ или документов ио проводника Windows или с рабочего стола в окно планировщика заданий.

Планировщик позволяет также изменять, удалять, приостанавливать и останавливать уже назначенные задания, просматривать журнал назначенных ранее заданий и просматривать задания, назначенные на удаленном компьютере.

Для получения дополнительных сведений об использовании планировщика заданий, см раздел Инструкции.

Опыт использования планировщика заданий

В системе Windows планировщик заданий позволяет назначить выполнение любого приложения. Чтобы воспользоваться преимуществами планировщика, перед добавлением задания убедитесь, что системные дата и время компьютера точно установлены.


Использование планировщика заданий и команды at

Планировщик заданий и команда At

В дополнение к планировщику заданий для автоматического назначения заданий можно воспользоваться также командой at.

Программа планировщика заданий не эквивалентна команде at, однако они могут работать совместно. Задание, назначенное с помощью команды at, появляется в списке заданий в окне "Назначенные задания".

Планировщик заданий можно использовать для изменения свойств задания, назначенного с помощью команды at. Однако после этого доступ к заданию становится возможным только с помощью планировщика заданий. Пользователь больше не сможет получить доступ к этому заданию с помощью команды at.

Для указания учетной записи пользователя, которая будет использоваться для выполнения заданий, назначенных с помощью команды at, в папке Мой компьютер, выберите значок папки "Назначенные задания", а затем в меню Дополнительно выберите команду Учетная запись службы AT.

Примечание

  • Служба AT доступна только в системе Windows NT.


Безопасность планировщика заданий

В планировщике заданий безопасность настраивается с помощью назначения имени и пароля пользователя для определенного задания. Если имя и пароль заданы, то задание не может быть отменено или удалено другим пользователем.

Примечания

  • Такое обеспечение безопасности доступно только в системе Windows NT.
  • Для продолжения планирования задания в мастере необходимо задать имя пользователя. Пароль не является обязательным.
  • Для изменения или задания нового пароля установите флажок Установить дополнительные параметры после нажатия кнопки "Готово" в последнем окне мастера.


Устранение неполадок планировщика заданий

Если запланированное задание не выполняется в назначенное время, щелкните правой кнопкой значок задания в списке заданий и выберите команду Свойства. На вкладке Задание проверьте, что установлен флажок Включено. На вкладке Расписание проверьте, правильно ли задано расписание.

Если неверно выполняется программа задания, проверьте, указаны ли все необходимые параметры командной строки. Чтобы больше узнать о программе и ее параметрах, выполните одно из следующих действий.

  • Если у программы имеется встроенная справка, просмотрите справку.

  • Введите в командную строку следующую команду: (где слово программа заменяет имя программы)

    • программа /?


Компонент Windows NT не установлен

Запуск программы невозможен.

Возможные причины:

    • программа была удалена администратором;
    • администратор изменил политику, связанную с данным файлом;
    • данная программа не установлена на компьютере;
    • программа была случайно удалена;
    • файл поврежден.

Если компьютер управляется администратором, попросите его выяснить, почему запуск этой программы невозможен.